Partial outage on Canadian Servers
Incident Report for SeamlessMD
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 00:07 UTC
Update
We are continuing to investigate this issue.
Posted Mar 14, 2024 - 23:02 UTC
Investigating
We had a partial outage earlier between 9:30AM to 10:00AM ET. We are currently investigating the cause. Please reach out to support@seamless.md if you are continuing to see errors.
Posted Mar 14, 2024 - 14:03 UTC
This incident affected: SeamlessMD Healthcare Provider Portal.