Experiencing slowdown on US servers
Incident Report for SeamlessMD
Resolved
We've identified the network issue and issued a fix. Performance/load speeds should be back to normal. We continue to monitor for any other issues.
Posted May 16, 2023 - 00:29 UTC
Investigating
We are currently investigating this issue.
Posted May 15, 2023 - 22:24 UTC
This incident affected: SeamlessMD Healthcare Provider Portal.