Heavy traffic
Incident Report for SeamlessMD
Resolved
Traffic has returned back to regular levels
Posted Aug 16, 2023 - 18:52 UTC
Update
We are continuing to investigate this issue.
Posted Aug 16, 2023 - 18:51 UTC
Investigating
We are experiencing higher than usual traffic and load times on our site this morning. In the meantime please try to wait a bit before accessing the portal while we investigate the cause.
Posted Aug 16, 2023 - 14:01 UTC
This incident affected: SeamlessMD Healthcare Provider Portal.